СРОЧНО,ПОМОГИТЕ!!! Напишите программы в pascal,пожалуйста. Вот задачки: 1.Написать...

0 голосов
55 просмотров

СРОЧНО,ПОМОГИТЕ!!! Напишите программы в pascal,пожалуйста. Вот задачки: 1.Написать программу, которая выводит таблицу кубов первых трех положительных четных чисел. 2.Написать программу, которая вычисляет сумму первых N целых положительных нечетных чисел. 3.Написать программу, которая вычисляет сумму первых N членов ряда 1,3,5,7,...Количество суммируемых членов ряда задается во время работы.


Информатика (349 баллов) | 55 просмотров
Дан 1 ответ
0 голосов

1)

var
n,i,kv:integer;
begin
kv:=1;
readln (n);
for i:=1 to n do
begin
if (i>0) and (i mod 2= 0) and (i<>0) then kv:=i*i*i;
writeln (kv);
end;
end.

 

2)

var
n,i,sum:integer;
begin
readln (n);
for i:=1 to n do
begin
if (i>0) and (i mod 2<>0) then sum:=sum+i;
end;
writeln (sum);
end.

 

 

 

 

(666 баллов)