Почему не работает запись в Паскале по задаче: Написать программу, подсчитывающую...

0 голосов
34 просмотров

Почему не работает запись в Паскале по задаче: Написать программу, подсчитывающую количество четных цифр, которые делятся на 4, в числе.
Вот запись, исправьте пожалуйста:
program chisla;
var a,b,k:integer;
begin
k:=0;
writeln('Введите число');
readln(a);
repeat
if(a mod 2=0)and(a mod 4=0)then
k:=k+1
until a=0;
writeln('Количество чисел=',k)
end.


Информатика (98 баллов) | 34 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var a,b,k:integer;
begin
k:=0;
writeln('Введите число');
readln(a);
repeat
if (a mod 10) in [4,8] then k:=k+1;
a:=a div 10;
until a=0;
writeln('Количество чисел=',k)
end.

Введите число
24583
Количество чисел=2


(5.1k баллов)