В классе 20 учеников писали диктант по русскому.Написать программу подсчета кол-ва 2 3 4...

0 голосов
82 просмотров

В классе 20 учеников писали диктант по русскому.Написать программу подсчета кол-ва 2 3 4 5 получивших за диктант


Информатика (74 баллов) | 82 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Const n=20;
var a:array[1..n] of integer;
  m:array[2..5] of byte;
i,k:integer;
begin
Randomize;
writeln('Оценки:');
for i:=1 to n do
 begin
 a[i]:=random(4)+2;
 write(a[i],' ');
 end;
writeln;
for i:=1 to n do inc(m[a[i]]);
writeln('Статистика:');
for i:=2 to 5 do writeln(i,' - ',m[i]);
end.

(194k баллов)