Как написать программу которая напишет все целые числа от 1 до 50 которые кратны 9 и...

0 голосов
90 просмотров

Как написать программу которая напишет все целые числа от 1 до 50 которые кратны 9 и посчитает их произведение и сумму


Информатика (12 баллов) | 90 просмотров
Дан 1 ответ
0 голосов

Берем цикл от 1 до 50, идем и проверяем все числа на кратность 9, если кратны, то пишем число и добавляем к сумме (и умножаем произведение).

 

var

  sum, mul, i : integer;

begin

   sum := 0; mul := 1;

  for i := 1 to 50 do

    if i mod 9 = 0 then

    begin

      write (i, '  ');

      sum := sum + i;

      mul := mul * i;

    end;

  writeln;

  writeln ('sum = ', sum);

  writeln ('mul = ', mul);

end.

(4.6k баллов)