Как составить программу, в которой нужно сначала ввести число, а по нему ввести...

0 голосов
31 просмотров

Как составить программу, в которой нужно сначала ввести число, а по нему ввести количество данных ? Например:
вводим:
5
6 7 8 4 3
2
4 5
(строки 6 7 8 4 3 и 4 5 тоже числа, которые нужно вводить)


Информатика (15 баллов) | 31 просмотров
0

Да так и составить. Читаем количество чисел, а затем в цикле от 1 до этого количества читаем сами числа.

Дан 1 ответ
0 голосов
Правильный ответ

Var a,b,c:integer;
begin
c:=0;
writeln('введите количество чисел');
readln(a);
writeln('введите числа ');
while (c<>a) do begin
 read(b);
c:=c+1;
end;
end.

(8.6k баллов)