Помогите написать программу ** Pascal ) Нужно, что бы программа выводила цикл. Вот такого...

0 голосов
59 просмотров

Помогите написать программу на Pascal ) Нужно, что бы программа выводила цикл. Вот такого содержания
12345
2345
345
45
5
Треугольником.


Информатика (78 баллов) | 59 просмотров
0

Всм треугольником

0

Вводи строку s:= '12345' и дальше удаляй первый delete(s,1,1) символ и выводи строку в цикле по writeln(s)

Дано ответов: 2
0 голосов
Правильный ответ

Var
i:longint;
s:string;
begin
s:='12345';
for i:=1 to 5 do
 begin
 writeln(S);
 delete(S,1,1);
 end;
end.



(514 баллов)
0

byte*

0

Вот именно ЗАДАНА

0

Строка уже задана в условии задачи, не так ли?

0

какое число больше 10000000 ты вобще о чем

0

а если число больше 1000000, тогда что будешь делать?

0

Всм ?

0

поставь 1,,5 и все

0

А что изменится если я поставлю bytу?

0

А зачем тратить лишние байты?

0

Там мудрить нечего не надо с 10000000 числами

0 голосов

Var A:integer;
S:String;
begin
Readln(A);
Str(A,S);
While not(S='') do
begin
Writeln(S);
Delete(S,1,1);
end;
end.

(1.6k баллов)
0

если не хочешь тогда так:
var S:String;
begin
Readln(S);
While not(S='') do
begin
Delete(S,1,1);
Writeln(S);
end;
end.

0

программа выводит правильно, т.к. ввод за вывод не считают

0

Вот такого содержания
12345
2345
345
45
5

0

Что не так?

0

Читать не чего не надо

0

Выводит так как надо (Если не считать вводимое число)