Дано целое число c.Напишите программу,которая возводит в квадрат частное от целочисленного деления числа с на 5 и выводит на экран монитора результат)
Var c: integer; begin read(c); writeln(sqr(c div 5)); end.
спасибо,а что значит "sqr"?
это функция возведения в квадрат выражения.
а зачем здесь div?
это функция целочисленного деления.
спасибо ещё раз)
Program del; var p, s: integer; begin writeln('Введите делимое'); readln(p); s:= sqr(p mod 5); Writeln('Остаток в квадрате =', s); end.
там частное надо возводить, а не остаток. плюс, ты задействуешь лишние переменные, что, несомненно, задействует больше памяти, а это всегда не очень хорошо для программы ~~
не mod, а div . Условие неверн опрочитал
прочитал