Написать программу ,которая проверяет,находится ли введенное с клавиатуры число в...

0 голосов
47 просмотров

Написать программу ,которая проверяет,находится ли введенное с клавиатуры число в массиве.Массив также должен вводиться во время программы.(ПАСКАЛЬ) С
ОБЪЯСНЕНИЕМ!
Заранее спасибо!!!


Информатика (65 баллов) | 47 просмотров
Дан 1 ответ
0 голосов

Вот так попробуй
var
a: array[1..10] of integer;
x, i: integer;
l: boolean;
begin
write('Введите ряд чисел - ');
//заполняем массив
for i:=1 to 10 do
read(a[i]);
//вводим число, которое нужно проверить
write('Введите число - ');
readln(x);
//проверяем, есть ли число в массиве
//если есть, то l будет присвоено true
for i:=1 to 10 do
if a[i] = x thenl := true;
//проверяем,чему равна l
if l=true then
writeln('Число ',x,' есть в массиве.')
else
writeln('Числа ',x,' нет в массиве.');
end.

(294 баллов)