Составьте программу вывода на экран n первых чисел Фибонаги (это числовая последовательность 1,1,2,3,5,8,23,...),которые вычисляются по правилу:а1=1,а2=1,а3=а2+а1,...,аn=аn-1+an-2(после -а- это индексы!!!)pascal ABC
Var i,n:integer; a,b:int64; begin read(n); a:=1; b:=1; if (n=1) then write(a) else if (n>=2) then write(a,', ',b); if (n>2) then for i:=1 to n-2 do begin b:=b+a; a:=b-a; write(', ',b); end; End.
Здесь прога покороче, но с массивом. Var i,n:integer; a:array[1..100] of int64; begin read(n); a[1]:=1; a[2]:=1; if (n>2) then for i:=3 to n do a[i]:=a[i-1]+a[i-2]; for i:=1 to n do write(a[i],', '); End.