Помогите написать программу ** паскале. "Написать программу,которая позволяет выставлять...

0 голосов
68 просмотров

Помогите написать программу на паскале.
"Написать программу,которая позволяет выставлять оценку за работу в зависимости от кол-ва сделанных ошибок."


Информатика (31 баллов) | 68 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program marks;
var
a,b:integer;
begin
Writeln('Введите кол-во сделанных ошибок: ');
readln(a);
b:=0;
if a=0 then b:=5;
if (a>0) and (a<=3) then b:=4;<br>if (a>3) and (a<=5) then b:=3;<br>if (a>5) then b:=2;
writeln('Оценка: ',b);
readln;
end.

(1.8k баллов)
0

Единственное что, ещё нужно дописать <= в условиях.

0

Ибо если ввести кол-во ошибок, равное, к примеру 5 или 3, программа выведет оценку 0.

0

Всё, исправил =)

0

большое спасибо.