Написать программу нахождения числа, если известен факториал числа ** Паскале

0 голосов
56 просмотров

Написать программу нахождения числа, если известен факториал числа на Паскале


Информатика (28 баллов) | 56 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var A,B:real;
Begin
B:=0;
Write('A! = ');ReadLn(A);
if A = 0 then Write('A = ',1) else Begin
While A/(B+1)<>1 do
Begin
B:=B+1;
A:=A/B;
End;
Write('A = ',A)
End
End.