Ниже записана программа. Получив ** вход число x , эта программа печатает два числа, L и...

0 голосов
58 просмотров

Ниже записана программа. Получив на вход число x , эта программа печатает два числа, L и M. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 7. var x, L, M: integer; begin readln(x); L:=0; M:=0; while x > 0 do begin L:= L 1; M:= M x mod 10; x:= x div 10; end; writeln(L); write(M); end.


Информатика (32 баллов) | 58 просмотров
Дан 1 ответ
0 голосов

 L - счётчик (сколько раз повторяется цикл) .
L=3 - поэтому у нас должно быть трёхзначное число.
M:=m+ x mod 10. - последовательно складываем все цифры числа x, в итоге должны получить 7.
 что максимальное число при таком раскладе - 700

(142 баллов)