Нужно написать программу - даны числа a,b,c.Составить программу вводящую их в убывающем...

0 голосов
80 просмотров

Нужно написать программу - даны числа a,b,c.Составить программу вводящую их в убывающем порядке


Информатика (20 баллов) | 80 просмотров
0

Язык программирования?

0

Да pascalABC

0

Там ещё тема моя есть не поможешь потом? 12 балов

0

А все числа разные? Или могут повторяться?

0

Ну на этот счёт не чего не сказано в задании.Могут

0

Ну по логике чиcло a должно быть отличным от b и от c

Дан 1 ответ
0 голосов
Правильный ответ

Var  a, b, c: integer;
begin  Writeln('Введите первое число');  readln(a);  Writeln('Введите второе число');  readln(b);  Writeln('Введите третье число');  readln(c);  if (A > B) and (A > C) and (B > C) then Writeln(a, b, c) else   if (B > A) and (B > C) and (A > C) then Writeln(b, a, c) else  if (C > A) and (C > B) and (B > A) Then writeln(c, b, a) else  if (A > B) AND (A > C) AND (C > B) THEN WRITELN(A, C, B) ELSE  if (B > A) AND (B > C) AND (C > A) THEN WRITELN(B, C, A) ELSE  if (C > A) AND (C > B) AND (A > B) THEN WRITELN(C, A, B);end.

(1.9k баллов)