Составить программу в Паскале. Вводится строка. Удвоить каждый ее символ.

0 голосов
110 просмотров

Составить программу в Паскале.

Вводится строка. Удвоить каждый ее символ.


Информатика (122 баллов) | 110 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Это делается очень просто:
var s,s1:string;i:integer;
begin
writeln('Введите строку:');
readln(s);
s1:='';
for i:=1 to length(s) do s1:=s1+s[i]+s[i];
s:=s1;
writeln(s);
end.

(194k баллов)