1.: Составить программу. Ввести 2 числа. Вычесть из большего меньшее. Ещё составить...

0 голосов
466 просмотров

1.: Составить программу. Ввести 2 числа. Вычесть из большего меньшее.

Ещё составить блок-схему!

____________________________

2. Составить блок-схему и программу. Условие задачи: Если хотя бы одно из трёх введенных пользователем чисел чётно, вывести слово "да". Иначе - вывести слово "нет".

____________________________

3. Исправить все ошибки в данном фрагменте программы:

If a>=10 and a<=99 Then</p>

Writeln (a ‘ двузначное число ’);

Writeln (‘ его квадрат = ’, Sqrt(a));

___________

Решите пожалуйста что сможете!


Информатика (85 баллов) | 466 просмотров
Дан 1 ответ
0 голосов

program z1;
var a,b,c:integer;
begin
write('a=');readln(a);
write('b=');readln(b);
if a>b then c:=a-b else c:=b-a;
writeln('c=',c);
end.

 

program z2;
var a,b,c:integer;
begin
write('a=');readln(a);
write('b=');readln(b);
write('c=');readln(c);
if ((a mod 2)=0)or((b mod 2)=0)or((c mod 2)=0)then writeln('четное') else writeln('нечетное');
end.

(535 баллов)