1)Напишите программу, которая вводит натуральное число N и нахо­ дит сумму всех...

0 голосов
116 просмотров

1)Напишите программу, которая вводит натуральное число N и нахо­
дит сумму всех натуральных чисел от 1 до N. Используйте сначала
цикл с условием, а потом — цикл с переменной.2)Напишите программу, которая вводит натуральное число N и выво­
дит первые N чётных натуральных чисел.3)Напишите программу, которая вводит натуральные числа а и Ь, и
выводит квадраты натуральных чисел в диапазоне от а до Ъ. Напри­
мер, если ввести 4 и 5, программа должна вывести:
4 * 4=16
5 * 5=25


Информатика (15 баллов) | 116 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

(Pascal)
1.
var
  i, s, n: integer;
begin
  readln(n);
  s := 0;
  i := 0;
  while i < n do
  begin
    i := i + 1;
    s := s + i;
  end;
  writeln('Цикл с предусловием: ', s);
  s := 0;
  i := 1;
  repeat
    s := s + i;
    i := i + 1;
  until i > n;
  writeln('Цикл с постусловием: ', s);
  s := 0;
  for i := 1 to n do
    s := s + i;
  writeln('Цикл с переменной: ', s);
end.

2.
var
  i, n: integer;
begin
  readln(n);
  for i := 1 to n do
    write(2 * i, ' ')
end.
3.
var
  i, a, b: integer;
begin
  readln(a, b);
  for i := a to b do
    writeln(i, ' * ', i, ' = ', i * i)
end.

(148k баллов)