ПОМОГИТЕ, ПОЖАЛУЙСТА. Напишите программу, которая получает день и номер месяца, а выводит...

0 голосов
128 просмотров

ПОМОГИТЕ, ПОЖАЛУЙСТА. Напишите программу, которая получает день и номер месяца, а выводит количество дней, оставшихся до Нового Года. Считайте, что год невисокосный (365 дней). Учтите, что слово «дней» может иметь также формы «день» и «дня».


Информатика (18 баллов) | 128 просмотров
0

Паскаль?

0

Да

0

ABC, turbo, free, ABC.net ?

0

ABC.net

0

Так нормально?

Дан 1 ответ
0 голосов

Var
День,Месяц:byte;
Begin
Write('№ дня = ');ReadLn(День);
Var C:=365-День;
Write('№ месяца = ');ReadLn(Месяц);
Case Месяц of
2:C:=C-31;
3:C:=C-59;
4:C:=C-90;
5:C:=C-120;
6:C:=C-151;
7:C:=C-181;
8:C:=C-212;
9:C:=C-243;
10:C:=C-273;
11:C:=C-304;
12:C:=C-334
End;
if (C mod 100>10)and(C mod 100<20) then Write('До нового года осталось ',C,' дней')<br>else
Case C mod 10 of
1:Write('До нового года остался ',C,' день');
2..4:Write('До нового года осталось ',C,' дня');
0,5..9:Write('До нового года осталось ',C,' дней')
End
End.

0

Спасибо большое!