Помогите написать программу в с++ . Очень надо. В произвольном тексте программа выводит...

0 голосов
30 просмотров

Помогите написать программу в с++ . Очень надо. В произвольном тексте программа выводит самое короткое слово.


Информатика (12 баллов) | 30 просмотров
Дан 1 ответ
0 голосов

//самое короткое слово
#include
#include
#include
using namespace std;

int main(int argc, char** argv) { 
  int i=0,j=0,l=0;
  char st[200];
  char ch=' ';
   cout<<" string:  ";   gets(st);  cout<<endl;<br>   string mins;
   int mn,bgmn,emn,tek;
  
mn=strlen(st);  bgmn=0;
 
    while (true)    {
         while ((st[j]!=ch) and (j         tek=j-l;
         for (int i=l; i         {  if (tek        if (j==strlen(st)) break;
        j++;  l=j;
  
}
//запись строки
    for (int i=bgmn; i<=emn; i++)   mins=mins+st[i];<br>    cout<<"short word:  "<<mins<<endl<<endl;<br>    system("pause");
    return(0);
}

(9.7k баллов)
0

Спасибо

0

Тока результат не выводит. Пишет много ошибок. Может в "С" надо делать.