Помогите написать программу ** паскале Перед всеми 3 большая фигурная скобка ...

0 голосов
29 просмотров

Помогите написать программу на паскале
Перед всеми 3 большая фигурная скобка
e^2x+e^3x+|корень х|, x<-2<br> N= e^2x-корень x^2 +2, -2≤x≤2
x^2 + x+1 \ lnx+ln2x, x>2


Информатика (17 баллов) | 29 просмотров
0

N= значит все три функции равны N?

0

Да да

Дан 1 ответ
0 голосов
Правильный ответ

Функции, конечно, распознаются с трудом. Возможно, что они такие:
var x,N:real;
begin
write('x=');readln(x);
if x<-2<br>   then N:=exp(2*x) + exp(3*x) + abs(sqrt(x))
  else if x<=2 then N:=exp(2*x) - sqrt(x*x+2)<br>               else N:=(x*x+x+1)/(ln(x)+ln(2*x));
writeln('N=',N);
end.

(194k баллов)