Написать программу ** алгоритмическом языке программирования для вычисления минимального...

0 голосов
68 просмотров

Написать программу на алгоритмическом языке программирования для вычисления минимального отрицательного числа и максимального положительного числа из 15 чисел введенных с клавиатуры(Язык с++)


Информатика (15 баллов) | 68 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

#include
using namespace std;
int main()
{   
int x, Max, Min;
x=Max=Min=0;
for (int i=1;i<=15;++i) {    <br>cin >> x;   
if (x > Max) Max=x;   
if (x < Min) Min=x;
}
cout << "Максимальное положительное число " << Max << " Минимальное отрицательное число " << Min << endl;<br>if (Max == 0 or Min == 0)    cout  << "Число 0 означает что такого значения нет" << endl;<br>}

(1.3k баллов)