Помогите составить программу ** языке программирования visual c++! Два автомобиля...

0 голосов
132 просмотров

Помогите составить программу на языке программирования visual c++!

Два автомобиля движутся по кольцевой дороге длины L в противоположных направлениях. Они начинают движение из одной точки и едут с постоянными скоростями v1 и v2 соответственно. Требуется определить, на каком расстоянии друг от друга они окажутся в момент времени T.

На вход подаются 4 натуральных числа L, v1, v2, T, разделенных пробелом. Все числа не превосходят 100.

Выведите расстояние между автомобилями в момент времени T – длину кратчайшей из двух дуг дороги между автомобилями.


Информатика (21 баллов) | 132 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

#include
using namespace std;
int main(){
  int l,v1,v2,t;
  cin>>l>>v1>>v2>>t;
  int x1 = (t * v1)%l,x2 = (-t*v2)%l;
  if(x1<0) x1=l-x1;<br>  if(x2<0) x2=l+x2;<br>  cout<<min(abs(x1-x2),abs(l-x1-x2));<br> }

(652 баллов)