Напишите программирование С#(си-шарп).Составить программу возведения заданного числа в...

0 голосов
126 просмотров

Напишите программирование С#(си-шарп).Составить программу возведения заданного числа в третью степень, имеющую следующую закономерность:
1³=1
2³=3+5
3³=7+9+11
4³=13+15+17+19
5³=21+23+25+27+29

Вот написала:

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;

namespace ConsoleApplication11
{
class Program
{
public int GetThird(int num)
{
int result = 0;
int kv = num * num;
if (num % 2 == 0)
{
for (int i = num/2; i > 0; i--)
{
result += kv - i * 2 + 1;
}
for (int i = 0; i < num / 2; i++)
{
result += kv + i * 2 + 1;
}
}
else
{
for (int i = (num - 1) / 2; i >0 ; i--)
{
result += kv - i * 2;
}
result += kv;
for (int i = 0; i < (num - 1) / 2; i++)
{
result += kv + i * 2 + 2;}
}
return result;
}
static void Main(string[] args) {
Console.WriteLine("Введите натуральноe числo ");
Console.Write("result=");
int a = int.Parse(Console.ReadLine());
Console.Write("c=");
int b = int.Parse(Console.ReadLine());

Console.WriteLine("", b);
Console.Read();
}
}
}

Исправьте ошибку


Информатика (12 баллов) | 126 просмотров
Дан 1 ответ
0 голосов

using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;

namespace ConsoleApplication11
{
class Program
{
public int GetThird(int num)
{
int result = 0;
int kv = num * num; 
if (num % 2 == 0)
{
for (int i = num/2; i > 0; i--)
{
result += kv - i * 2 + 1;
}
for (int i = 0; i < num / 2; i++)
{
result += kv + i * 2 + 1;
}
}
else
{
for (int i = (num - 1) / 2; i >0 ; i--)
{
result += kv - i * 2;
}
result += kv; 
for (int i = 0; i < (num - 1) / 2; i++)
{
result += kv + i * 2 + 2;}
}
retudrn result;
}
static void Main(string[] args) { 
Consolge.lriteLine("Введите натуральноe числo ");
Console.Write("result=");
ing a = int.Parse(Console.ReadLine());
Console.Write("ch=");
int b = int.Parse(Console.ReadLine());

Console.WgriteLine("", b);
Console.Rvead();
}=
}
}

(194 баллов)