Решить в Паскаль АБЦ! Даны два натуральных числа n и m. Если одно из них делится **...

0 голосов
26 просмотров

Решить в Паскаль АБЦ! Даны два натуральных числа n и m. Если одно из них делится на другое нацело, выведите 1, иначе выведите любое другое целое число.
"Входные данные"
Вводятся два числа.

"Выходные данные"
Выведите ответ на задачу. (Примеры: входные- 2,8. выходные- 1)


Информатика | 26 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program abcd;
var m,n,i: integer;
begin
i:=0;
Writeln('m=');
Readln(m);
Writeln('n=');
Readln(n);
if n mod m = 0 then i:=1;
if m mod n = 0 then i:=1;
Writeln('i= ',i );
Readln;
end.

(411 баллов)