Программирование алгоритмов ветвления Для заданного преподавателем варианта задания...

0 голосов
130 просмотров

Программирование алгоритмов ветвления
Для заданного преподавателем варианта задания составьте программу, которая
вычисляет значение выражения Входные данные: x, y – переменные вещественного типа.
Все входные данные вводятся с клавиатуры. Выходные данные: z – переменные
вещественного типа. Все выходные данные выводятся на экран монитора.
В c++


Информатика (27 баллов) | 130 просмотров
0

не знал что c++ в школе учат

Дан 1 ответ
0 голосов
Правильный ответ

#include
#include

using namespace std;

int main() {
    float x, y, z;
    cin >> x >> y;
    if (x <= 0) {<br>        z = pow(3 * pow(x, 5) + y * y, (float) 1 / 7);
    } else if (x > 0 && abs(y) >= x) {
        z = atan(x * y);
    } else {
        z = log(5 * x - abs(y)) / log(4);
    }
    cout << z;<br>    return 0;
}

(13.3k баллов)
0

В программе была ошибка из-за целочисленного деления, исправил