(Составить программу,массивы) Записать в массив 30 случайных чисел от 2 до 40 . Вывести...

0 голосов
41 просмотров

(Составить программу,массивы)
Записать в массив 30 случайных чисел от 2 до 40 . Вывести на экран номера тех элементов массива, значение которых кратно 7


Информатика (185 баллов) | 41 просмотров
Дан 1 ответ
0 голосов

Var a: array[1..30] of Integer;
 i: Integer;
Begin
  write('Кратные 7: ');
  for i := 1 to 30 do
  begin
    a[i] :=random(39) + 2;
    if a[i] mod 7 = 0 then write(a[i],' ');
  end;
End.

(505 баллов)