Очень срочно! Нужна ваша помощь! Написать программу ** паскале: сформировать матрицу и...

0 голосов
56 просмотров

Очень срочно! Нужна ваша помощь!
Написать программу на паскале: сформировать матрицу и найти наименьшее среди средних арифметических элементов ее столбцов.( В ответе достаточно рабочего кода)


Информатика (83 баллов) | 56 просмотров
0

"В ответе достаточно рабочего кода" - а что еще может быть в ответе, когда просят программу? Трактат о смысле жизни?

0

В прошлый раз мне скидывали саму программу на паскале, которая потом не открылась. Но если вы такой специалист по трактатам, то что ж, удивите меня.

0

Удивиться желаете, стало быть? Ну что же... вот Вам решение на Паскале, удивляйтесь. И код рабочий, и тестовое решение получено на реальном прогоне программы.

Дан 1 ответ
0 голосов
Правильный ответ

//PascalABC.Net 3.0, сборка 1064
type
  IntArray = array of integer;

var
  rows, cols: integer;
  M: array of IntArray;

begin
  Write('Количество строк и столбцов матрицы: '); Read(rows, cols);
  var Avg: array of double := new double[cols];
  M := new IntArray[rows];
  SetLength(Avg, cols);
  for var i := 0 to rows - 1 do
  begin
    M[i] := ArrRandom(cols, -25, 25);
    M[i].Println(#9)
  end;
  for var j := 0 to cols - 1 do
    Avg[j] := Range(0, rows - 1).Select(x -> M[x, j]).Average;
  Writeln('Наименьшее среднее по столбцам равно ', Avg.Min)
end.

Тестовое решение:
Количество строк и столбцов матрицы: 5 8
-22    -8    12    7    3    -18    8    22
2    -16    17    -13    -10    0    -19    2
20    -21    -6    13    2    -20    25    24
-7    -3    -2    -10    -2    8    18    23
4    -21    -8    8    23    -12    -13    -5
Наименьшее среднее по столбцам равно -13.8


(142k баллов)