Составьте программу которая позволяет ввести строки s, затем после каждой буквы "а"...

0 голосов
67 просмотров

Составьте программу которая позволяет ввести строки s, затем после каждой буквы "а" вставляет пробел. Pascal ABC, срочно


Информатика (135 баллов) | 67 просмотров
0

Строки или строку?

Дан 1 ответ
0 голосов
Правильный ответ

// PascalABC.NET 3.0, сборка 1076
var
  s:string;
  i,n:integer;
begin
  Write('Введите строку: '); ReadLn(s);
  for i:=Length(s) downto 1 do
    if s[i]='а' then Insert(' ',s,i+1);
  Writeln('Результат: ',s)
end.

Тестовое решение:
Введите строку: Это тестовая строка. Маша ела кашу.
Результат: Это тестова я строка . Ма ша  ела  ка шу.

(142k баллов)