Напишите программу пожалуйста): Ввести 15 целых элементов массива, элемента с нечетными...

0 голосов
52 просмотров

Напишите программу пожалуйста):

Ввести 15 целых элементов массива, элемента с нечетными номерами увеличить на 10, элементы с четными номерами уменьшить на 10. Вывести на экран


Информатика (195 баллов) | 52 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

USES CRT;
VAR A:array[1..15] of integer;
    i:integer;
BEGIN
CLRSCR;

{Заполняем массив}
For i:=1 to 15 do
 begin
   Write('Введите ',i,' элемент массива  ');
   Read(A[i]);
   CLRSCR;
 end;

{Выводим массив на экран}
For i:=1 to 15 do
 Write(A[i],'   ');

{К нечетным номерам массива +10 к четным -10}
For i:=1 to 15 do
 if i mod 2 <>0 then A[i]:=A[i]+10
                else A[i]:=A[i]-10;

Writeln;

{Выводим на экран измененный массив}
For i:=1 to 15 do
 Write(A[i],'   ');

Readln;
READLN;
END.


image
(246 баллов)
0

спасибо огромное

0

рад был помочь )