Напишите программу, которая вводит два числа A и N вычисляет A^N. Програмный код. НЕ через "power". Заранее спасибо
Function Pow(a : Integer; b : Integer) : Integer; Begin If b=0 then Pow:=1 else Pow:=a*Pow(a,b-1); End; Var A,N : Integer; Begin Readln(A,N); Writeln(Pow(A,N)); end.
Не Вам решать какая у меня голова. Если так, то сможете вообще расписать подробно как получить любое число в любой степени
Не вводя функции подобные этой, а получить расписав через "while", например,"for","repeat"
Так что же Вы сразу не обозначили эти условия задачи? Вы думаете тут все телепаты и понимают то, что Вы недоговариваете? Что спросили - на то и получили ответ.
придёт модератор и нас рассудит
Претензии имеете ко мне?
Я? Никаких. Свое решение я привёл в рамках Ваших первоначально заданных условиях - и мое решение, по моему мнению, полностью отвечает условиям.
"Не вводя функции подобные этой, а получить расписав через "while", например,или "for" " Если распишите, чтобы понятно все было, то высказываю свою благодарность Вам и забираю свои упреки и недовольства обратно.
Var R,A,N : Integer; Begin Readln(A,N); R:=1; While N>0 do Begin R:=R*A; Dec(N); end; Writeln(R); end.
Спасибо^^.