Составить программу выводящую ** экран все делители ** число х.(число х вводится с...

0 голосов
58 просмотров

Составить программу выводящую на экран все делители на число х.(число х вводится с клавиатуры)


Информатика (37 баллов) | 58 просмотров
Дан 1 ответ
0 голосов

program ml;
uses crt;
var x,i:integer;
    w,l:real;
begin
clrscr;
readln(x);
L:=x;
for i:=1 to x do                         begin
w:=w+1;
l:=x/w;
if frac(l) = 0 then writeln(l:2:0);
                                                end;
readkey;
end.

(1.2k баллов)