1) Написать программу вывода ** экран четвертую степень числа от n до 1. 2) Написать...

0 голосов
51 просмотров

1) Написать программу вывода на экран четвертую степень числа от n до 1.
2) Написать программу для вычисления диагонали параллелепипеда , если известны стороны .
3) Написать программу для вычисления у для функции у=под корнем тангенс


Информатика (15 баллов) | 51 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//Pascal ABC.NET Версия 2.2 Сборка 790
1)var i,n:integer;
begin;
readln(n);
for i:=n downto 1 do
writeln(sqr(sqr(i)));
end.

2)var a,b,c,d:real;
begin;
readln(a);
readln(b);
readln(c);
if (a<0) or (b<0) or (c<0) then exit;<br>d:=sqrt(sqr(a)+sqr(b)+sqr(c));
writeln(d);
end.

3)
var x,y:real;
begin;
readln(x);
if (x<0) or (x>1) then exit;
y:=sqrt(tan(x));
writeln(y);
end.

(38.6k баллов)
0

Правильно ?

0

Нет, что ты, я всегда выкладываю неверные решения. А если серьёзно, меня немного беспокоят исключения в 1 примере.