Ребят, помогите очень срочно! Написать программу задачи: дано все 3-х значные числа...

0 голосов
31 просмотров

Ребят, помогите очень срочно!
Написать программу задачи: дано все 3-х значные числа найти сумму и количество чисел которые кратны 9.


Информатика (28 баллов) | 31 просмотров
0

А что там писать? Первое трехзначное число кратное 9, это 108. А дальше с шагом 9 пошли.... закончив 999.

0

да я сама толком не понимаю..

0

ооокей

0

Что там писать, я уже ответил

0

Три оператора? Могу, но это позорище))) Пусть кто-то другой напишет)))

0

а ты можешь написать всю эту программу?

0

Арифметическая прогрессия с разностью 9. Есть начальный и конечный члены, есть разность. Количество членов и их сумма находятся по готовой формуле. Программа будет состоять из операторов begin; write(); end. В операторе вывода пишем нужные формулы.

Дан 1 ответ
0 голосов

Var
  i, a, p: integer;

begin
  a := 0;
  p := 0;
  for i := 100 to 999 do
  begin
    if i mod 9 = 0 then
    begin
      a := a + i;
      p := p + 1;
    end;
  end;
  writeln('Сумма = ', a);
  writeln('Кол-во чисел = ', p);
end.


image
(10.7k баллов)
0

Никто и не спорит, просто в условии сказано, что даны все трёхзначные числа, вот и программа проверяет все)

0

развели базар какой то

0

я по этому предмету не собираюсь сдавать ЕГЭ.

0

А при сдаче экзамена в вуз могут и два снять.

0

Даже в несчастном ЕГЭ за решение, подобное Вашему снимают 1 балл.

0

Тогда, уверяю, Ваша программа и за неделю не закончит расчет....

0

А если будет сказано, что даны все шестнадцатизначные числа и надо выбрать кратные миллиону, Вы тоже будете все проверять?

0

Можно хотя бы пройти от 108 с шагом 9. Это во-первых. А во-вторых, "никто не говорил" вообще ничего, что способы решения ограничены, поэтому можно и через прогрессию...

0

никто не говорил, что нужно через прогрессию решать, хоть она там и есть, можно сделать что бы программа за тебя всё посчитала и проверила)

0

Да-да, Вы правы, все чудесно))))