Напишите программу для ABC Pascal для вывода n числа Фибоначчи, где n <=40. Массив не...

0 голосов
70 просмотров

Напишите программу для ABC Pascal для вывода n числа Фибоначчи, где n <=40. Массив не использовать


Информатика (335 баллов) | 70 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var    a,b,c,i,n: integer;
begin   
write('n = ');   
readln(n);    
a := 0;   
write(a,' ');    b := 1;    write(b,' ');   
 for i:=3 to n do begin     
  write(a+b,' ');       
 c := b;       
b := a + b;       
a := c   
 end;end.

(6.5k баллов)
0

А как вывести только последнее число и обозначить, что n<=40?

0

все write закоментировать

0

end;
writeln(b);
end.

0

добавить

0

Спасибо