Напишите программу, которая вычисляет сумму всех двухзначных чисел.

0 голосов
103 просмотров

Напишите программу, которая вычисляет сумму всех двухзначных чисел.


Информатика (203 баллов) | 103 просмотров
0

Можно через repeat<действие> until<условие>

Дан 1 ответ
0 голосов
Правильный ответ

Var a,b:integer;
begin
a:=0;
for b:=10 to 99 do
a:=a+b;
writeln (a);
end. 

Через repeat 

program znanija;
var a,b:integer;
begin
a:=0;
b:=10;

repeat
a:=a+b;
inc(b); // Прибавляем единицу к переменной b. Тоже самое что b:=b+1;
until b>99;

writeln (a);
end. 

(778 баллов)
0

Можно через repeat<действие> until<условие> ? Просто через for....to мы не делали через while....do можно

0

Добавил в решение

0

inc(b) что значит

0

Тоже самое что и b:=b+1;

0

Спасибо, огромное:3

0

Пожалуйста