Помогите плиз написать программу в паскале Найти сумму чётных натуральных чисел в...

0 голосов
34 просмотров

Помогите плиз написать программу в паскале
Найти сумму чётных натуральных чисел в промежутке от n1 до n2.
Pascal ABC.


Информатика (494 баллов) | 34 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
1. "Школьное" решение
// PascalABC.Net 3.0, сборка 1064
var
  i,n1,n2:integer;
  s:longint;
begin
  Write('Введите интервал для вычисления суммы: '); Read(n1,n2);
  s:=0;
  if n1 mod 2 = 0 then i:=n1 else i:=n1+1;
  while i<=n2 do begin s:=s+i; i:=i+2 end;<br>  Writeln('Сумма четных чисел в интервале равна ',s)
end.

Тестовое решение:
Введите интервал для вычисления суммы: 7 14
Сумма четных чисел в интервале равна 44

2. Современное решение
// PascalABC.Net 3.0, сборка 1064
var
  n1,n2:integer;
begin
  Write('Введите интервал для вычисления суммы: '); Read(n1,n2);
  if Odd(n1) then Inc(n1);
  Writeln('Сумма четных чисел в интервале равна ',Range(n1,n2,2).Sum);
end.
(142k баллов)
0

Исправил описку в комментарии PascalABC.Net

0

Ок) Спасибо большое)

0

Пожалуйста