Написать программу в ПАСКАЛЕ, которая проверяет, есть ли во введенном с клавиатуры...

0 голосов
87 просмотров

Написать программу в ПАСКАЛЕ, которая проверяет, есть ли во введенном с клавиатуры массиве элементы с одинаковым значением. Пожалуйста подробно...


Информатика (101 баллов) | 87 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

var a:array [1..100] of integer;

n,i,j:integer;

f:boolean;

BEGIN

  read(n);

  f:=false;

  for i := 1 to n do begin

    readln(a[i]);

    for j:= 1 to i-1 do

      f=f or (a[i]=a[j]);

  end;

  writeln(f);

 

END.

(53.1k баллов)