60 Балов Написать программу решения квадратного уравнения: Ax²+Bx+C=0

0 голосов
70 просмотров

60 Балов
Написать программу решения квадратного уравнения:
Ax²+Bx+C=0


Информатика (48 баллов) | 70 просмотров
0

Ограничения есть какие-то? Например A не равно нулю и т.д.?

0

ytne

0

нету

0

Тогда Ваша программа должна быть весьма велика... При А=0 нужно писать решение линейного уравнения и т.д.

0

информатичка задала...

0

Ну тут как бы можно попробовать искусственно заявить, что А не должно быть равно нулю, потому что тогда уже уравнение не будет квадратным, но это, конечно же отговорки.

0

а вы можете помочь?

0

Какой язык программирования?

0

А еще - не стоит врать про 60 баллов, поскольку реально-то 15+8 за решение.

0

Это ненаказуемо, но создает не очень хорошее впечатление о Вас.

Дано ответов: 2
0 голосов
Правильный ответ

Var
  a,b,c,D,x1,x2:double;
begin
  Write('Введите коэффициенты квадратного уравнения А В С: ');
  Read(a,b,c);
  if a=0 then
    Writeln('А не может равняться нулю: уравнение не будет квадратным')
  else begin
    D:=sqr(b)-4*a*c;
    if D<0 then Writeln('Нет корней')<br>    else
      if D=0 then Writeln('x=',-b/(2*a))
      else begin
        D:=sqrt(D);
        x1:=(-b-D)/(2*a); x2:=(-b+D)/(2*a);
        Writeln('x1=',x1,', x2=',x2)
      end
  end
end.

Тестовое решение:
Введите коэффициенты квадратного уравнения А В С: 2 -5 3
x1=1, x2=1.5

(142k баллов)
0 голосов

Var a,b,c,D,x1,x2:double; begin Write('Введите коэффициенты квадратного уравнения А В С: '); Read(a,b,c); if a=0 then Writeln('А не может равняться нулю: уравнение не будет квадратным') else begin D:=sqr(b)-4*a*c; if D<0 then Writeln('Нет корней') else if D=0 then Writeln('x=',-b/(2*a)) else begin D:=sqrt(D); x1:=(-b-D)/(2*a); x2:=(-b+D)/(2*a); Writeln('x1=',x1,', x2=',x2) end end end. Тестовое решение: Введите коэффициенты квадратного уравнения А В С: 2 -5 3 x1=1, x2=1.5 ответ у модератора совершенно верен.

(393 баллов)