Написать программу while ..do Ввести с клавиатуры 10 чисел. Если квадрат числа меньше...

0 голосов
56 просмотров

Написать программу while ..do
Ввести с клавиатуры 10 чисел. Если квадрат числа меньше 100, напечатать число и его квадрат.


Информатика (89 баллов) | 56 просмотров
Дан 1 ответ
0 голосов

Одно из возможных решений. Также можно использовать массив, если это необходимо за условием.

const
  n = 10;
var
  i, number: integer;
begin
  i := 1;
  while (i <= n) do<br>    begin
      write('Введите ', i, '-ое число: ');
      readln(number);
      if sqr(number) < 100 then
          writeln('Число: ', number, '. Квадрат числа: ', sqr(number), '.');
      Inc(i);
    end
end.

(418 баллов)
0

Благодарю