Составить программу, которая формирует массив из 5 случайных чисел от -10 до 15. а) найти...

0 голосов
28 просмотров

Составить программу, которая формирует массив из 5 случайных чисел от -10 до 15.
а) найти элементы равные 1.
б) найти индекс нечетных элементов.
в) Найти количество положительных элементов.


Информатика | 28 просмотров
0

На каком языке?

Дан 1 ответ
0 голосов
Правильный ответ

Const n=5;
var a : array[1..n] of integer;
     k,i : integer;
begin
Randomize;
 for i:=1 to n do
 begin
  a[i]:=random(26)-10;
  write(a[i],' ');
 end;
writeln;
 writeln('элементы равные 1 имеют номера:');
for i:=1 to n do if a[i]=1 then write(i:3);
writeln;
writeln('индексы нечетных элементов:');
for i:=1 to n do if a[i] mod 2<>0 then write(i:3);
writeln;
k:=0;
for i:=1 to n do if a[i]>0 then k:=k+1;
writeln('количество положительных элементов=',k);
end.

(194k баллов)