Написать программу Попадёт ли точка в заданную область

0 голосов
42 просмотров

Написать программу Попадёт ли точка в заданную область


image

Информатика (14 баллов) | 42 просмотров
0

я правильно понимаю, что у окружности радиус 1? Следовательно координаты точек это не целые числа?

0

если бы я знал, она такая решайте эту задачу, а как не сказала

0

Программу на Pascal ?

0

да

0

ну так подойти надо было и спросить, "не сказала". Это тебе потом если что по шее получать, поэтому надо беспокоится и добиваться своего.

Дан 1 ответ
0 голосов

Var
Begin
  if (x<=0) and (y<=0) and (sqr(x)+sqr(y)<=1) or (sqr(x)+sqr(y)<=1) and (y>=0)         then write('Yes')
  else write ('No');
end.
 

(67 баллов)
0

var x,y:integer

0

Забыла.