80 БАЛЛОВ!!!Помогите Паскаль!!!Нужно составить программу которая проверяла является ли...

0 голосов
36 просмотров

80 БАЛЛОВ!!!Помогите Паскаль!!!Нужно составить программу которая проверяла является ли простым числом,введенное с клавиатуры числом


Информатика (1.0k баллов) | 36 просмотров
Дан 1 ответ
0 голосов

Program zhn;
var
  n,i,sum:integer;
begin
  write('Введите значение: ');
  readln(n);
  for i:=1 to n do begin
    if n mod i = 0 then sum:=sum+1;
  end;
  if sum = 2 then writeln('Число ',n,' является простым.')
  else writeln('Число ',n,' НЕ является простым.');
 
end.

(795 баллов)
0

а что за sum

0

Просто простое число имеет только два делителя, я это прверяю если количество делителей больше двух. Значит число не простое. А в sum просто записываю количество делителей

0

а будет ошибкой если я напишу в место sum.напишу х

0

без разницы

0

f cgfcb,j

0

главное что бы везде было x

0

спасибо

0

вместо sum