Помогите, пожалуйста с номером 40. Нужно написать программу в Pascal, используя цикл...

0 голосов
24 просмотров

Помогите, пожалуйста с номером 40. Нужно написать программу в Pascal, используя цикл repeat until. Первая часть есть:

program a1;
var y, i, a, x: integer;
begin
writeln ('введите значение x');
readln (x);
y:=0;
i:=x;
a:=cos (x);
repeat
y:=y+a


image

Информатика (195 баллов) | 24 просмотров
Дан 1 ответ
0 голосов

Program a1;
var y, a, x, n, i,b: integer;
begin
writeln ('введите значение x и n');
readln (n);
y:=0;
i: = x;
a:=cos (x);
repeat
y:=y+a;

i:=i*x;
a:=cos(i);
inc(b);
until bi >=10) do
writeln(y);
end.

(514 баллов)
0

если надо не как в задании лучше напиши