Написать программу в Паскале (ВВОДИТЬ ЧИСЛА ДО ТЕХ ПОР ПОКА ОЧЕРЕДНОЕ НЕ ОКАЖЕТСЯ РАВНО...

0 голосов
50 просмотров

Написать программу в Паскале (ВВОДИТЬ ЧИСЛА ДО ТЕХ ПОР ПОКА ОЧЕРЕДНОЕ НЕ ОКАЖЕТСЯ РАВНО 0,НАЙТИ СУММУ ЧИСЕЛ С ЧЕТНЫМ ПОРЯДКОВЫМ НОМЕРОМ)


Информатика (17 баллов) | 50 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var a,i,s:integer;
begin
write('a='); readln(a);
s:=0;i:=1;
while a<>0 do
 begin
 if i mod 2 =0 then s:=s+a;
 i:=i+1;
 write('a='); readln(a);
end;
writeln('s=',s);
end.

(194k баллов)