Составьте программу ,которая уменьшает первое число в пять раз ,если оно больше второго

0 голосов
76 просмотров

Составьте программу ,которая уменьшает первое число в пять раз ,если оно больше второго


Информатика (15 баллов) | 76 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var a,b:real;
begin
writeln('Введите 2 числа');
read(a,b);
if a>b then 
   begin 
      writeln('Первое число больше второго'); 
      write('a=',a/5:0:2); 
   end
else  writeln('Первое число не больше второго');
end.

(314k баллов)
0

Круто по модулю брать. Если входные данные -10 и -5, то получается, что -10 больше чем -5.

0

Это не число БОЛЬШЕ, а МОДУЛЬ.

0

Просто без модуля будет правильный ответ.

0

А кто НАПИСАЛ этот МОДУЛЬ..

0

У вас, братцы ошибка. Число а НЕ РАЗДЕЛИЛОСЬ, а только написалось "маленьким". Надо а:=а/5; writeln(a);

0

Да, это тоже ошибка. В двух ответах нет ни одного правильного.

0 голосов

Var   A,B,C:integer;
begin
A=10;
B=9;
IF AЭто фрагмент РЕШЕНИЯ задачи.

(500k баллов)
0

Это решение также является неправильным. По условию задачи нужно, чтоб первое число уменьшалось, ЕСЛИ ОНО больше второго, а не наоборот, как написано в этом решении, а конкретно IF A < B. Правильным вариантом будет IF A > B