Дано вещественное число. Напишите программу, которая возводит в квадрат целую часть...

0 голосов
59 просмотров

Дано вещественное число. Напишите программу, которая возводит в квадрат целую часть данного числа и выводит на экран монитора результат.


Информатика (12 баллов) | 59 просмотров
Дан 1 ответ
0 голосов

program test;
var number: real; temp: integer;
begin
   write('Enter the number: ');
   readln(number);

   temp:=trunc(number);
   writeln(temp, '^2=', temp*temp);

   readln;
end.

(2.0k баллов)