PascalABC. Дан одномерный массив целых чисел от -20 до 30 из 15 элементов задан через...

0 голосов
61 просмотров

PascalABC.
Дан одномерный массив целых чисел от -20 до 30 из 15 элементов задан через генератор случайных чисел. Составить программу подсчета чисел элементов массива больших его пятого элемента.


Информатика (91 баллов) | 61 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

//PascalABC.Net 3.0, сборка 1053
const
  n=15;
var
  a:array[1..n] of integer;
  i,s:integer;
begin
  Randomize;
  Writeln('Исходный массив');
  for i:=1 to n do begin
    a[i]:=Random(51)-20;
    Write(a[i],' ')
  end;
  Writeln;
  s:=0;
  for i:=1 to n do
    if a[i]>a[5] then s:=s+a[i];
  Writeln('Сумма искомых элементов равна ',s)
end.

Тестовое решение:
Исходный массив
-10 0 -10 -13 11 7 13 7 -2 -11 12 19 -20 10 -3
Сумма искомых элементов равна 44

(142k баллов)