Составьте программу,которая выводит ** экран нечетные числа от 1 до 50 в порядке убывания.

0 голосов
52 просмотров

Составьте программу,которая выводит на экран нечетные числа от 1 до 50 в порядке убывания.


Информатика (14 баллов) | 52 просмотров
0

в смысле программу ?

0

в abc паскаль

Дан 1 ответ
0 голосов

//PascalABC.NET
var
i:integer;
begin
for i:=50 downto 1 do
if i mod 2 =1 then writeln(i);
end.

(1.3k баллов)
0

а если мы не проходили downto? то как

0

var
i:integer;
begin
i:=50;
while i > 0 do begin
if i mod 2 = 1 then write(i,' ');
i:=i-1;
end;
end.

0

спасибо)