Ниже записана программа. Получив ** вход число x , эта программа печатает два числа, L и...

0 голосов
487 просмотров

Ниже записана программа. Получив на вход число x , эта программа печатает два числа, L и M. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 7.

var x, L, M: integer;
begin
readln(x);
L:=0; M:=0;
while x > 0 do begin
L:= L + 1;
M:= M + x mod 10;
x:= x div 10;
end;
writeln(L); write(M);
end.


Информатика (72 баллов) | 487 просмотров
Дано ответов: 2
0 голосов

Наименьшим из таких чисел x будет 700.

 

(62 баллов)
0 голосов

106. L - количество разрядов, M - хз.  Решение- http://rghost.ru/43591476

(22 баллов)