надо составить программу в паскале, в которой надо найти процент от заданного числа

0 голосов
72 просмотров

надо составить программу в паскале, в которой надо найти процент от заданного числа


Информатика (15 баллов) | 72 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var     
q: Single; // Результат. Если число будет больше, то указать Double
i: Single; // Число из которого необходимо получить результат. Если число будет больше, то указать Double
p: Single; // Процент. Если процент будет всегда целым числом, то указать Byte
begin 
writeln('Введите число => '); 
read(i); 
writeln('Введите процент, который хотите расcчитать из введенного числа => ');   
read(p); 
while p < 0 do
begin     
writeln('Процент не может быть меньше нуля, введите новое значение => ');   
read(p);   
end; 
q:=(i / 100) * p; 
writeln('Ваш результат из числа => ', i, ', ', p, '% = ', q);
end.

(127 баллов)