Срочно прошу помощи!!!ПАСКАЛЬ 8 КЛАСС! Напишите программу, которая строит таблицу...

0 голосов
26 просмотров

Срочно прошу помощи!!!ПАСКАЛЬ 8 КЛАСС!
Напишите программу, которая строит таблицу истинности для логической формулы (not a)or(not b)or c. Подумайте сколько вложенных циклов вам понадобиться.


Информатика (161 баллов) | 26 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Uses Crt;
var
  a,b,c:boolean;
begin
  ClrScr;
  for a:=False to True do
  for b:=False to True do
  for c:=False to True do
  Writeln(a:6,b:6,c:6,(not a) or (not b) or c:6);
  ReadKey
end.

Результат выполнения программы:
 FALSE FALSE FALSE  TRUE
 FALSE FALSE  TRUE  TRUE
 FALSE  TRUE FALSE  TRUE
 FALSE  TRUE  TRUE  TRUE
  TRUE FALSE FALSE  TRUE
  TRUE FALSE  TRUE  TRUE
  TRUE  TRUE FALSE FALSE
  TRUE  TRUE  TRUE  TRUE

(142k баллов)